Archiv für 'EMC' Kategorie

QLogic ISP2XXX v8.02.11 Linux-Treiber ab Kernel 2.6.20

Was QLogic mit diesem Treiber fabriziert ist mir nicht ganz klar. Mit der Version 8.02.11 vom 26. März 2008 wurde eine Prüfung eingebaut, welche die Kompilation auf Kernelversionen >2.6.19 verhindern soll:

Restrict driver compilation to kernels less-than 2.6.20.

Eine Begründung hierzu liegt im Changelog nicht vor. Anstatt also den Treiber endlich den aktuellen (derzeit v2.6.25) Kernelversionen anzupassen, werden dem Administrator einfach die flapsigen Fehlermeldungen

In file included from /root/src/qla2xxx-8.02.13/qla_iocb.c:7:
/root/src/qla2xxx-8.02.13/qla_def.h:34:2: error:
#error "This driver does not support kernel versions greater than 2.6.19."
In file included from /root/src/qla2xxx-8.02.13/qla_isr.c:7:
/root/src/qla2xxx-8.02.13/qla_def.h:34:2: error:
#error "This driver does not support kernel versions greater than 2.6.19."
In file included from /root/src/qla2xxx-8.02.13/qla_init.c:7:
/root/src/qla2xxx-8.02.13/qla_def.h:34:2: error:
#error "This driver does not support kernel versions greater than 2.6.19."
In file included from /root/src/qla2xxx-8.02.13/qla_os.c:7:
/root/src/qla2xxx-8.02.13/qla_def.h:34:2: error:
#error "This driver does not support kernel versions greater than 2.6.19."
make[1]: *** [/root/src/qla2xxx-8.02.13/qla_iocb.o] Fehler 1

entgegengeschleudert. Abhilfe schafft hier die Modifikation der “qla_def.h” des Quelltext-Pakets:

#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,19)
#error "This driver does not support kernel versions greater than 2.6.19."

Anzumerken ist trotzdem, dass der Treiber nur bis Kernel-Version 2.6.23 funktioniert. Hier hat QLogic dringenden Korrekturbedarf. Jedoch liegt die Vermutung nahe, dass eine Anpassung erst dann geschehen wird, wenn RHEL und/oder SLES entsprechende Kernelversionen verwenden.